Arquivo do Autor: Felipe Gualberto

Sobre Felipe Gualberto

Microsoft Most Valuable Professional (MVP) de Excel.

Referências Absolutas e Relativas

Uma referência no Excel é a representação de uma célula ou intervalo numa fórmula. Por exemplo, na fórmula: =SOMA(A5;B$3) Há duas referências: A5 e B$3. Existem dois tipos de referência no Excel: relativa e absoluta. As referências são identificadas num … Continue lendo

Publicado em Tutoriais | Com a tag , , , , | Deixar um comentário

Visual Basic Editor (VBE)

Para desenvolver em VBA, é necessário abrir um dos aplicativos Office, como o Excel ou Word. O ambiente de desenvolvimento da linguagem VBA chama-se Visual Basic Editor (VBE) e a forma mais fácil mostra-lo (ou oculta-lo) é pressionando Alt+F11 na … Continue lendo

Publicado em Tutoriais | Com a tag , , , , , | Deixar um comentário

Expor Membros de um Projeto no Intellisense

O VBE é uma IDE que possui algumas deficiências, e nesta postagem é mostrado como expandir a funcionalidade do intellisense.

Publicado em Ferramentas | Com a tag , , , , , , , , | Deixar um comentário

Jogo da Serpente em Excel

Lembram do Snake para celulares Nokia? Resolvi fazer uma versão para o Excel.

Publicado em Jogos | Com a tag , , , | 4 comentários

Gerar Árvore de Arquivos e Diretórios no Excel

Você pode usar o Excel para varrer um caminho local ou de rede e mostrar os arquivos e/ou diretórios (que chamarei neste artigo de itens) numa tabela, criando uma árvore de itens. Na pasta de trabalho que preparei, você pode … Continue lendo

Publicado em Ferramentas | Com a tag , , , , , | 11 comentários

AmbienteXL

Versão atual: 1.01 (25/05/2015) O AmbienteXL (que antes se chamava ExpressXL) é um suplemento gratuito para Excel 2007 ou superior que desenvolvi em VBA e expande as funcionalidades do aplicativo.

Publicado em Ferramentas | Com a tag , | 13 comentários

Melhorar o Desempenho do PROCV

Todos que usam Excel já passaram por esse cenário uma vez: há uma pasta de trabalho que possui uma tabela muito grande e há diversos PROCV e demora muito tempo para recalcula-la. Neste artigo vou mostrar como tornar seu PROCV … Continue lendo

Publicado em Dicas | Com a tag , , , , , , , | 18 comentários

Introdução a Módulos de Classe no VBA

O VBA suporta o uso de classes através de componentes chamados módulos de classe. Classes são usadas para criar objetos.

Publicado em Tutoriais | Com a tag , , , , , , , , , | 10 comentários