ÍNDICE

A função ÍNDICE é nativa do Excel e faz parte do grupo de funções de Pesquisa e Referência.

Introdução

ÍNDICE é uma função versátil que pode ser utilizada de várias maneiras. Em sua forma mais básica, retorna o valor de um determinado índice num vetor.

No exemplo abaixo, estou buscando o 4o elemento da lista mais recente de presidentes do Brasil:

A fórmula em E5 é:

=ÍNDICE(B4:B13;4)

No caso acima, a sintaxe é:

=ÍNDICE(matriz;núm_linha)

A fórmula traz o elemento de um determinado vetor, ou seja, o elemento número núm_linha de matriz.

ÍNDICE também funciona horizontalmente. Adaptando o exemplo anterior:

A fórmula em B6 é:

=ÍNDICE(B4:B13;4)

Neste caso, o parâmetro núm_linha, na verdade, torna-se núm_coluna.

Matriz

ÍNDICE funciona também em matrizes. O exemplo abaixo possui uma fórmula que retorna o resultado da 2a linha e 3a coluna:

A fórmula em B15 é:

=ÍNDICE(B4:E13;2;3)

O resultado é PT. Neste caso, a sintaxe de ÍNDICE está na forma:

=ÍNDICE(matriz;núm_linha;núm_coluna)

Áreas

Você pode ter, como parâmetro de matriz, várias tabelas e extrair o elemento de uma delas com ÍNDICE. No exemplo abaixo, escrevi uma fórmula para obter a quantidade de pontos ganhos pela equipe de Costa do Marfim:

A fórmula em B19 é:

=ÍNDICE((B6:J9;L6:T9;B13:J16;L13:T16);3;2;3)

Note que ao especificar as áreas, você deve colocá-las entre parênteses e separá-las com ;, ficando na forma (área1;área2;área3;...).

ÍNDICE adquire a forma abaixo, neste caso:

=ÍNDICE(matriz;núm_linha;núm_coluna;núm_área)

No exemplo, preenchendo os argumentos obtive a 3a linha da 2a coluna da 3a área, cujo resultado é 3.

Se você não especificar o número da área e tiver várias áreas no argumento matriz, a primeira área será considerada.

Nesse exemplo usei intervalos de tamanho igual, mas você pode usar intervalos de diferentes formatos e eles podem, inclusive, se sobrepor.

Erros

  • Se núm_linha, núm_coluna ou núm_área não apontarem para um índice dentro dos limites especificados, obterá o erro #REF!. Isso inclui querer obter, por exemplo, a 10a linha do intervalo A1:A5.
  • Se o argumento matriz for um intervalo com mais de uma linha e uma coluna e você não especificar o parâmetro núm_coluna, obterá o erro #REF!. Se não especificar núm_linha, obterá o erro #VALOR!.
  • Se você preencher com argumentos não numéricos núm_linha, núm_coluna ou núm_área, obterá o erro #VALOR!.

Download

Para fazer download da pasta de trabalho usada neste artigo, clique aqui.

Sobre Felipe Gualberto

Microsoft Most Valuable Professional (MVP) de Excel.
Esta entrada foi publicada em Tutoriais e marcada com a tag , , . Adicione o link permanente aos seus favoritos.